Problema al instalar vlc en debian 9

Foros

instalando vlc con el siguiente comando apt install vlc tengo el siguiente error:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 vlc : Depende: vlc-plugin-video-output (= 1:3.0.2-dmo1+deb9u2) pero 1:2.2.8-dmo1+deb9u1 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

 

Acerca del autor

Pentesting. Estudiante de ingeniería en sistemas y mantenimiento de sistemas informáticos. UNA 

Submitted byJ3ss3SHLon Vie, 15/06/2018 - 16:30


# deb http://debian.uniminuto.edu/debian/ stretch main

#deb http://debian.uniminuto.edu/debian/ stretch main
#deb-src http://debian.uniminuto.edu/debian/ stretch main

# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main 
deb-src http://ftp.us.debian.org/debian/ stretch-updates main 

# stretch-oficiales
deb http://ftp.us.debian.org/debian/ stretch main 
deb-src http://ftp.us.debian.org/debian/ stretch main 

# stretch-actualizaciones-seguridad
deb http://security.debian.org/debian-security stretch/updates main 
deb-src http://security.debian.org/debian-security stretch/updates main 

# stretch-actualizaciones-sistema
deb http://mirrors.kernel.org/debian/ stretch-updates main 
deb-src http://mirrors.kernel.org/debian/ stretch-updates main 
deb http://mirrors.kernel.org/debian stretch-proposed-updates main 
deb-src http://mirrors.kernel.org/debian stretch-proposed-updates main 

# debian-multimedia
# apt-get install deb-multimedia-keyring
deb http://www.deb-multimedia.org stretch main 
#deb [ trusted=yes ] http://www.deb-multimedia.org stable main non-free
#deb https://riot.im/packages/debian/ stretch main

# tor
deb http://deb.torproject.org/torproject.org stretch main
deb-src http://deb.torproject.org/torproject.org stretch main

#backport
#deb http://ftp.us.debian.org/debian stretch-backports main

deb http://http.kali.org/kali kali-rolling main contrib non-free


#deb http://download.virtualbox.org/virtualbox/debian stretch contrib

#deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main
#deb https://riot.im/packages/debian/ stretch main

#deb http://deb.debian.org/debian/ unstable main contrib non-free
#deb-src http://deb.debian.org/debian/ unstable main contrib non-free

Eso es lo que tengo en los repositorios. :v

Submitted byEdu4rdSHLon Vie, 15/06/2018 - 16:36

Probablemente se deba a un conflicto generado por las versiones en los repositorios de Kali Linux y Debian. Añade # al inicio del repositorio de Kali Linux, luego ejecutas:

apt update

Seguidamente ejecutas:

apt remove vlc && apt autoremove

Finalmente

apt install vlc
Submitted byJ3ss3SHLon Vie, 15/06/2018 - 20:24

Se soluciono el problema comentando # los repositorios innecesarios, también se descargo he   instalo el paquete vlc-plugin-video-output y todas sus dependencias de forma manual lo cual podrás encontrar en su pagina oficial https://packages.debian.org/stretch/vlc-plugin-video-output

Usando el comando en el directorio Descargas el siguiente comando:

dpkg -i vlc-plugin-video-output_3.0.2-0+deb9u1_i386.deb

Si en caso que arroje este error como dije. se debe descargar he instalar de forma manual cada una de sus dependencias. 

dpkg -i nombre-de-la-dependencia
dpkg -i vlc-plugin-video-output_3.0.2-0+deb9u1_i386.deb 
Seleccionando el paquete vlc-plugin-video-output:i386 previamente no seleccionado.
(Leyendo la base de datos ... 199638 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar vlc-plugin-video-output_3.0.2-0+deb9u1_i386.deb ...
Desempaquetando vlc-plugin-video-output:i386 (3.0.2-0+deb9u1) ...
dpkg: problemas de dependencias impiden la configuración de vlc-plugin-video-output:i386:
 vlc-plugin-video-output:i386 depende de libgles2-mesa (>= 7.8.1) | libgles2; sin embargo:
  El paquete `libgles2-mesa' no está instalado.
  El paquete `libgles2' no está instalado.
 vlc-plugin-video-output:i386 depende de libva-wayland1 (>= 1.3.0); sin embargo:
  El paquete `libva-wayland1' no está instalado.
 vlc-plugin-video-output:i386 depende de libvlccore9 (>= 3.0.2); sin embargo:
  El paquete `libvlccore9' no está instalado.
 vlc-plugin-video-output:i386 depende de libxcb-xv0 (>= 1.2); sin embargo:
  El paquete `libxcb-xv0' no está instalado.
 vlc-plugin-video-output:i386 depende de vlc-plugin-abi-3-0-0f; sin embargo:
  El paquete `vlc-plugin-abi-3-0-0f' no está instalado.

dpkg: error al procesar el paquete vlc-plugin-video-output:i386 (--install):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 vlc-plugin-video-output:i386

luego se procede a instalar con el comando:

apt install vlc

Nota: tomen en cuenta que los comando lo estoy realizado como root.